1
0
mirror of https://github.com/NixOS/nixos-hardware synced 2024-06-02 19:13:33 +02:00
nixos-hardware/microsoft/surface/surface-go/firmware/ath10k/ath10k-replace.nix
mexisme 03df3d2d53 Move files around...
- "kernel" and "repos.nix" --> "common/"
- "firmware/surface-go/ath10k" --> "surface-go/firmware/ath10k"
- Update where "kernel", "firmware/surface-go" and "repos.nix" can be found
2023-01-10 15:38:47 +13:00

27 lines
847 B
Nix

{ stdenv, lib, pkgs, firmwareLinuxNonfree, ... }:
let
repos = pkgs.callPackage ../../../common/repos.nix {};
killernetworking_firmware = repos.surface-go-ath10k-firmware_backup + "/K1535_Debian";
in stdenv.mkDerivation {
pname = "microsoft-surface-go-firmware-linux-nonfree";
inherit (firmwareLinuxNonfree) version;
src = firmwareLinuxNonfree;
phases = [ "unpackPhase" "installPhase" ];
installPhase = ''
# Install the Surface Go Wifi firmware:
cp ${killernetworking_firmware}/board.bin lib/firmware/ath10k/QCA6174/hw2.1/
cp ${killernetworking_firmware}/board.bin lib/firmware/ath10k/QCA6174/hw3.0/
mkdir $out; cp -r ./. $out
'';
meta = with lib; {
description = "Standard binary firmware collection, adjusted with the Surface Go WiFi firmware";
platforms = platforms.linux;
priority = 5;
};
}