nixos-hardware/starfive/visionfive/v2/uboot.nix

17 lines
273 B
Nix

{ buildUBoot
, opensbi
}:
buildUBoot {
extraMakeFlags = [
"OPENSBI=${opensbi}/share/opensbi/lp64/generic/firmware/fw_dynamic.bin"
];
defconfig = "starfive_visionfive2_defconfig";
filesToInstall = [
"spl/u-boot-spl.bin.normal.out"
"u-boot.itb"
];
}