1
0
mirror of https://github.com/NixOS/nixos-hardware synced 2024-06-02 11:03:33 +02:00
nixos-hardware/pine64/star64/spl-tool.nix
Francesco Gazzetta 30f71ba6e0 star64: init
Mostly based on the visionfive 2 config.
No GPU yet.
2023-07-07 21:54:40 +02:00

19 lines
458 B
Nix

{ stdenv, fetchFromGitHub }:
stdenv.mkDerivation rec{
pname = "spi_tool";
version = "unstable-2023-04-14";
src = fetchFromGitHub {
owner = "starfive-tech";
repo = "Tools";
rev = "693661d4ba314424f76c06da1bbb799e9b534c9f";
hash = "sha256-POWwpIIPnquJs/bpC3Pn94skua3SZvyfICPBglO7HnU=";
sparseCheckout = [ "spl_tool" ];
};
sourceRoot = "source/spl_tool";
installPhase = ''
mkdir -p $out/bin
cp spl_tool $out/bin
'';
}