mirror of
https://github.com/nix-community/home-manager
synced 2024-11-01 00:39:45 +01:00
23 lines
518 B
Nix
23 lines
518 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
with lib;
|
|
|
|
{
|
|
meta.maintainers = [ maintainers.rycee ];
|
|
|
|
options = {
|
|
services.tahoe-lafs = { enable = mkEnableOption "Tahoe-LAFS"; };
|
|
};
|
|
|
|
config = mkIf config.services.tahoe-lafs.enable {
|
|
assertions = [
|
|
(hm.assertions.assertPlatform "services.tahoe-lafs" pkgs platforms.linux)
|
|
];
|
|
|
|
systemd.user.services.tahoe-lafs = {
|
|
Unit = { Description = "Tahoe-LAFS"; };
|
|
|
|
Service = { ExecStart = "${pkgs.tahoelafs}/bin/tahoe run -C %h/.tahoe"; };
|
|
};
|
|
};
|
|
}
|