mirror of
https://github.com/nix-community/home-manager
synced 2024-11-01 00:39:45 +01:00
41 lines
895 B
Nix
41 lines
895 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
with lib;
|
|
|
|
let
|
|
|
|
cfg = config.services.playerctld;
|
|
|
|
in {
|
|
meta.maintainers = [ hm.maintainers.fendse ];
|
|
|
|
options.services.playerctld = {
|
|
enable = mkEnableOption "playerctld daemon";
|
|
|
|
package = mkOption {
|
|
type = types.package;
|
|
default = pkgs.playerctl;
|
|
defaultText = literalExpression "pkgs.playerctl";
|
|
description = "The playerctl package to use.";
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
assertions = [
|
|
(lib.hm.assertions.assertPlatform "services.playerctld" pkgs
|
|
lib.platforms.linux)
|
|
];
|
|
|
|
systemd.user.services.playerctld = {
|
|
Unit.Description = "MPRIS media player daemon";
|
|
|
|
Install.WantedBy = [ "default.target" ];
|
|
|
|
Service = {
|
|
ExecStart = "${cfg.package}/bin/playerctld";
|
|
Type = "dbus";
|
|
BusName = "org.mpris.MediaPlayer2.playerctld";
|
|
};
|
|
};
|
|
};
|
|
}
|