mirror of
https://github.com/nix-community/home-manager
synced 2024-11-01 00:39:45 +01:00
5f433eb164
Before, loading a module would be guarded by an optional platform condition. This made it possible to avoid loading and evaluating a module if it did not support the host platform. Unfortunately, this made it impossible to share a single configuration between GNU/Linux and Darwin hosts, which some wish to do. This removes the conditional load and instead inserts host platform assertions in the modules that are platform specific. Fixes #1906
37 lines
865 B
Nix
37 lines
865 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
with lib;
|
|
|
|
let
|
|
|
|
cfg = config.services.mpris-proxy;
|
|
|
|
in {
|
|
meta.maintainers = [ maintainers.thibautmarty ];
|
|
|
|
options.services.mpris-proxy.enable = mkEnableOption
|
|
"a proxy forwarding Bluetooth MIDI controls via MPRIS2 to control media players";
|
|
|
|
config = mkIf cfg.enable {
|
|
assertions = [
|
|
(lib.hm.assertions.assertPlatform "services.mpris-proxy" pkgs
|
|
lib.platforms.linux)
|
|
];
|
|
|
|
systemd.user.services.mpris-proxy = {
|
|
Unit = {
|
|
Description =
|
|
"Proxy forwarding Bluetooth MIDI controls via MPRIS2 to control media players";
|
|
BindsTo = [ "bluetooth.target" ];
|
|
After = [ "bluetooth.target" ];
|
|
};
|
|
|
|
Install.WantedBy = [ "bluetooth.target" ];
|
|
|
|
Service = {
|
|
Type = "simple";
|
|
ExecStart = "${pkgs.bluez}/bin/mpris-proxy";
|
|
};
|
|
};
|
|
};
|
|
}
|