mirror of
https://github.com/nix-community/home-manager
synced 2024-11-01 00:39:45 +01:00
5f433eb164
Before, loading a module would be guarded by an optional platform condition. This made it possible to avoid loading and evaluating a module if it did not support the host platform. Unfortunately, this made it impossible to share a single configuration between GNU/Linux and Darwin hosts, which some wish to do. This removes the conditional load and instead inserts host platform assertions in the modules that are platform specific. Fixes #1906
38 lines
798 B
Nix
38 lines
798 B
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
with lib;
|
|
|
|
let
|
|
|
|
cfg = config.services.caffeine;
|
|
|
|
in {
|
|
meta.maintainers = [ maintainers.uvnikita ];
|
|
|
|
options = {
|
|
services.caffeine = { enable = mkEnableOption "Caffeine service"; };
|
|
};
|
|
|
|
config = mkIf cfg.enable {
|
|
assertions = [
|
|
(lib.hm.assertions.assertPlatform "services.caffeine" pkgs
|
|
lib.platforms.linux)
|
|
];
|
|
|
|
systemd.user.services.caffeine = {
|
|
Unit = { Description = "caffeine"; };
|
|
|
|
Install = { WantedBy = [ "graphical-session.target" ]; };
|
|
|
|
Service = {
|
|
Restart = "on-failure";
|
|
PrivateTmp = true;
|
|
ProtectSystem = "full";
|
|
ProtectHome = "yes";
|
|
Type = "exec";
|
|
Slice = "session.slice";
|
|
ExecStart = "${pkgs.caffeine-ng}/bin/caffeine";
|
|
};
|
|
};
|
|
};
|
|
}
|