mirror of
https://github.com/nix-community/home-manager
synced 2024-11-01 00:39:45 +01:00
1ebbef8642
`--enable-crypto` is deprecated because crypto is now enabled by default. `--disable-crypto` should be used instead. Fixes https://github.com/nix-community/home-manager/issues/3001
79 lines
2 KiB
Nix
79 lines
2 KiB
Nix
{ config, lib, pkgs, ... }:
|
|
|
|
with lib;
|
|
let cfg = config.services.barrier;
|
|
in {
|
|
|
|
meta.maintainers = with maintainers; [ kritnich ];
|
|
|
|
imports = [
|
|
(mkRemovedOptionModule [ "services" "barrier" "client" "tray" ] ''
|
|
The tray option is non-functional and has been removed.
|
|
'')
|
|
];
|
|
|
|
options.services.barrier = {
|
|
|
|
client = {
|
|
|
|
enable = mkEnableOption "Barrier Client daemon";
|
|
|
|
name = mkOption {
|
|
type = types.nullOr types.str;
|
|
default = null;
|
|
description = ''
|
|
Screen name of client. Defaults to hostname.
|
|
'';
|
|
};
|
|
|
|
server = mkOption {
|
|
type = types.str;
|
|
description = ''
|
|
Server to connect to formatted as
|
|
<literal><host>[:<port>]</literal>.
|
|
Port defaults to <literal>24800</literal>.
|
|
'';
|
|
};
|
|
|
|
enableCrypto = mkEnableOption "crypto (SSL) plugin" // {
|
|
default = true;
|
|
};
|
|
|
|
enableDragDrop = mkEnableOption "file drag & drop";
|
|
|
|
extraFlags = mkOption {
|
|
type = types.listOf types.str;
|
|
default = [ "-f" ];
|
|
defaultText = literalExpression ''[ "-f" ]'';
|
|
description = ''
|
|
Additional flags to pass to <command>barrierc</command>.
|
|
See <command>barrierc --help</command>.
|
|
'';
|
|
};
|
|
|
|
};
|
|
};
|
|
|
|
config = mkIf cfg.client.enable {
|
|
assertions = [
|
|
(lib.hm.assertions.assertPlatform "services.barrier" pkgs
|
|
lib.platforms.linux)
|
|
];
|
|
|
|
systemd.user.services.barrierc = {
|
|
Unit = {
|
|
Description = "Barrier Client daemon";
|
|
After = [ "graphical-session-pre.target" ];
|
|
PartOf = [ "graphical-session.target" ];
|
|
};
|
|
Install.WantedBy = [ "graphical-session.target" ];
|
|
Service.ExecStart = with cfg.client;
|
|
toString ([ "${pkgs.barrier}/bin/barrierc" ]
|
|
++ optional (name != null) "--name ${name}"
|
|
++ optional (!enableCrypto) "--disable-crypto"
|
|
++ optional enableDragDrop "--enable-drag-drop" ++ extraFlags
|
|
++ [ server ]);
|
|
};
|
|
};
|
|
|
|
}
|