mirror of
https://github.com/nix-community/home-manager
synced 2024-11-01 00:39:45 +01:00
da3b8049fd
This lets fcitx5 be used within the kitty terminal emulator. See https://wiki.archlinux.org/title/Kitty#Enable_IME_support for more.
43 lines
1 KiB
Nix
43 lines
1 KiB
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
with lib;
|
|
|
|
let
|
|
im = config.i18n.inputMethod;
|
|
cfg = im.fcitx5;
|
|
fcitx5Package = pkgs.fcitx5-with-addons.override { inherit (cfg) addons; };
|
|
in {
|
|
options = {
|
|
i18n.inputMethod.fcitx5 = {
|
|
addons = mkOption {
|
|
type = with types; listOf package;
|
|
default = [ ];
|
|
example = literalExpression "with pkgs; [ fcitx5-rime ]";
|
|
description = ''
|
|
Enabled Fcitx5 addons.
|
|
'';
|
|
};
|
|
};
|
|
};
|
|
|
|
config = mkIf (im.enabled == "fcitx5") {
|
|
i18n.inputMethod.package = fcitx5Package;
|
|
|
|
home.sessionVariables = {
|
|
GLFW_IM_MODULE = "ibus"; # IME support in kitty
|
|
GTK_IM_MODULE = "fcitx";
|
|
QT_IM_MODULE = "fcitx";
|
|
XMODIFIERS = "@im=fcitx";
|
|
};
|
|
|
|
systemd.user.services.fcitx5-daemon = {
|
|
Unit = {
|
|
Description = "Fcitx5 input method editor";
|
|
PartOf = [ "graphical-session.target" ];
|
|
};
|
|
Service.ExecStart = "${fcitx5Package}/bin/fcitx5";
|
|
Install.WantedBy = [ "graphical-session.target" ];
|
|
};
|
|
};
|
|
|
|
}
|