1
0
Fork 0
mirror of https://github.com/nix-community/home-manager synced 2025-02-17 05:35:06 +01:00
home-manager/tests/modules/services/podman-linux/integration.nix
Robert Helgesson 7a3f0b3b8d
tests: rework derivation stubbing
Instead of having to manually stub packages that should not be
downloaded we instead automatically stub all packages (except a small
list of whitelisted ones). Tests can re-introduce the real package by
using the `realPkgs` module argument.
2025-02-04 23:58:20 +01:00

29 lines
840 B
Nix

{
imports = [ ./podman-stubs.nix ];
services.podman = {
enable = true;
containers."my-container" = {
image = "docker.io/alpine:latest";
network = [ "my-net" "externalnet" ];
};
networks."my-net" = {
gateway = "192.168.123.1";
subnet = "192.168.123.0/24";
};
};
nmt.script = ''
configPath=home-files/.config/systemd/user
containerFile=$configPath/podman-my-container.service
networkFile=$configPath/podman-my-net-network.service
assertFileExists $containerFile
assertFileExists $networkFile
containerFile=$(normalizeStorePaths $containerFile)
networkFile=$(normalizeStorePaths $networkFile)
assertFileContent $containerFile ${./integration-container-expected.service}
assertFileContent $networkFile ${./integration-network-expected.service}
'';
}