1
0
Fork 0
mirror of https://github.com/nix-community/home-manager synced 2025-02-17 05:35:06 +01:00
home-manager/tests/modules/services/picom/picom-basic-configuration.nix
Robert Helgesson 7a3f0b3b8d
tests: rework derivation stubbing
Instead of having to manually stub packages that should not be
downloaded we instead automatically stub all packages (except a small
list of whitelisted ones). Tests can re-introduce the real package by
using the `realPkgs` module argument.
2025-02-04 23:58:20 +01:00

33 lines
882 B
Nix

{
services.picom = {
enable = true;
fade = true;
fadeDelta = 5;
fadeSteps = [ 4.0e-2 4.0e-2 ];
fadeExclude =
[ "window_type *= 'menu'" "name ~= 'Firefox$'" "focused = 1" ];
shadow = true;
shadowOffsets = [ (-10) (-15) ];
shadowOpacity = 0.8;
shadowExclude =
[ "window_type *= 'menu'" "name ~= 'Firefox$'" "focused = 1" ];
backend = "xrender";
vSync = true;
settings = {
"unredir-if-possible" = true;
"dbe" = true;
};
extraArgs = [ "--legacy-backends" ];
};
nmt.script = ''
assertFileContent \
home-files/.config/picom/picom.conf \
${./picom-basic-configuration-expected.conf}
serviceFile=$(normalizeStorePaths home-files/.config/systemd/user/picom.service)
assertFileContent \
"$serviceFile" \
${./picom-basic-configuration-expected.service}
'';
}