mirror of
https://github.com/nix-community/home-manager
synced 2024-11-26 21:19:45 +01:00
bd58a1132e
The systemd user service depends on config.xdg.configFile."hypr/hyprpaper.conf".source for `X-Restart-Triggers`. When `cfg.settings` is the default `{}`, this causes failure since config.xdg.configFile."hypr/hyprpaper.conf".source will not exist. Making the addition conditional on `cfg.settings` actually having content, which would mean `xdg.configFile."hypr/hyprpaper.conf"` does exist, avoids the error.
17 lines
339 B
Nix
17 lines
339 B
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
services.hyprpaper = {
|
|
enable = true;
|
|
settings = { };
|
|
};
|
|
|
|
test.stubs.hyprpaper = { };
|
|
|
|
nmt.script = ''
|
|
config=home-files/.config/hypr/hyprpaper.conf
|
|
clientServiceFile=home-files/.config/systemd/user/hyprpaper.service
|
|
assertPathNotExists $config
|
|
assertFileExists $clientServiceFile
|
|
'';
|
|
}
|