1
0
Fork 0
mirror of https://github.com/nix-community/home-manager synced 2024-11-26 21:19:45 +01:00
home-manager/tests/modules/services/hypridle/no-configuration.nix
Sebastián Zavala Villagómez 5e2f47c5a5
hypridle: fix service when no config file
The systemd user service depends on

  config.xdg.configFile."hypr/hypridle.conf".source

for `X-Restart-Triggers`. When `cfg.settings` is the default `{}`,
this causes failure since

  config.xdg.configFile."hypr/hypridle.conf".source

will not exist.

Making the addition conditional on `cfg.settings` actually having
content, which would mean `xdg.configFile."hypr/hypridle.conf"` does
exist, avoids the error.
2024-11-24 17:41:50 +01:00

14 lines
302 B
Nix

{ pkgs, ... }:
{
services.hypridle.enable = true;
test.stubs.hypridle = { };
nmt.script = ''
config=home-files/.config/hypr/hypridle.conf
clientServiceFile=home-files/.config/systemd/user/hypridle.service
assertPathNotExists $config
assertFileExists $clientServiceFile
'';
}