mirror of
https://github.com/nix-community/home-manager
synced 2024-11-26 21:19:45 +01:00
5e2f47c5a5
The systemd user service depends on config.xdg.configFile."hypr/hypridle.conf".source for `X-Restart-Triggers`. When `cfg.settings` is the default `{}`, this causes failure since config.xdg.configFile."hypr/hypridle.conf".source will not exist. Making the addition conditional on `cfg.settings` actually having content, which would mean `xdg.configFile."hypr/hypridle.conf"` does exist, avoids the error.
14 lines
302 B
Nix
14 lines
302 B
Nix
{ pkgs, ... }:
|
|
|
|
{
|
|
services.hypridle.enable = true;
|
|
|
|
test.stubs.hypridle = { };
|
|
|
|
nmt.script = ''
|
|
config=home-files/.config/hypr/hypridle.conf
|
|
clientServiceFile=home-files/.config/systemd/user/hypridle.service
|
|
assertPathNotExists $config
|
|
assertFileExists $clientServiceFile
|
|
'';
|
|
}
|