mirror of
https://github.com/nix-community/home-manager
synced 2025-02-17 05:35:06 +01:00
Instead of having to manually stub packages that should not be downloaded we instead automatically stub all packages (except a small list of whitelisted ones). Tests can re-introduce the real package by using the `realPkgs` module argument.
23 lines
522 B
Nix
23 lines
522 B
Nix
{
|
|
programs.yt-dlp = {
|
|
enable = true;
|
|
settings = {
|
|
embed-thumbnail = true;
|
|
embed-subs = false;
|
|
sub-langs = "all";
|
|
downloader = "aria2c";
|
|
downloader-args = "aria2c:'-c -x8 -s8 -k1M'";
|
|
trim-filenames = 30;
|
|
};
|
|
extraConfig = ''
|
|
--config-locations /home/user/.yt-dlp.conf
|
|
'';
|
|
};
|
|
|
|
nmt.script = ''
|
|
assertFileExists home-files/.config/yt-dlp/config
|
|
assertFileContent home-files/.config/yt-dlp/config ${
|
|
./yt-dlp-simple-config-expected
|
|
}
|
|
'';
|
|
}
|