1
0
Fork 0
mirror of https://github.com/nix-community/home-manager synced 2025-02-17 05:35:06 +01:00
home-manager/tests/modules/programs/yazi/init-lua-string.nix
Robert Helgesson 7a3f0b3b8d
tests: rework derivation stubbing
Instead of having to manually stub packages that should not be
downloaded we instead automatically stub all packages (except a small
list of whitelisted ones). Tests can re-introduce the real package by
using the `realPkgs` module argument.
2025-02-04 23:58:20 +01:00

12 lines
195 B
Nix

{
programs.yazi = {
enable = true;
initLua = builtins.readFile ./init.lua;
};
nmt.script = ''
assertFileContent home-files/.config/yazi/init.lua \
${./init.lua}
'';
}