1
0
Fork 0
mirror of https://github.com/nix-community/home-manager synced 2025-04-15 02:45:11 +02:00
home-manager/tests/modules/programs/tmux/default-shell.nix
Austin Horstman cba2f9ce95 treewide: reformat nixfmt-rfc-style
Reformat repository using new nixfmt-rfc-style.
2025-04-08 08:50:05 -07:00

26 lines
463 B
Nix

{ pkgs, ... }:
let
substituteExpected =
path:
pkgs.substituteAll {
src = path;
sensible_rtp = pkgs.tmuxPlugins.sensible.rtp;
};
in
{
config = {
programs.tmux = {
enable = true;
shell = "/usr/bin/myshell";
};
nmt.script = ''
assertFileExists home-files/.config/tmux/tmux.conf
assertFileContent home-files/.config/tmux/tmux.conf \
${substituteExpected ./default-shell.conf}
'';
};
}