1
0
Fork 0
mirror of https://github.com/nix-community/home-manager synced 2025-02-17 05:35:06 +01:00
home-manager/tests/modules/programs/tmate/tmate.nix
Robert Helgesson 7a3f0b3b8d
tests: rework derivation stubbing
Instead of having to manually stub packages that should not be
downloaded we instead automatically stub all packages (except a small
list of whitelisted ones). Tests can re-introduce the real package by
using the `realPkgs` module argument.
2025-02-04 23:58:20 +01:00

21 lines
589 B
Nix

{
programs.tmate = {
enable = true;
port = 222;
dsaFingerprint = "SHA256:1111111111111111111111111111111111111111111";
extraConfig = ''set tmate-session-name "session-name"'';
};
nmt.script = let
expectedConfig = ''
set -g tmate-server-port 222
set -g tmate-server-ed25519-fingerprint "SHA256:1111111111111111111111111111111111111111111"
set tmate-session-name "session-name"
'';
in ''
assertFileExists home-files/.tmate.conf
assertFileContent home-files/.tmate.conf ${
builtins.toFile "config" expectedConfig
}
'';
}