mirror of
https://github.com/nix-community/home-manager
synced 2025-02-17 05:35:06 +01:00
Instead of having to manually stub packages that should not be downloaded we instead automatically stub all packages (except a small list of whitelisted ones). Tests can re-introduce the real package by using the `realPkgs` module argument.
17 lines
337 B
Nix
17 lines
337 B
Nix
{
|
|
programs.sftpman = {
|
|
enable = true;
|
|
|
|
mounts = {
|
|
mount1 = {
|
|
host = "host1.example.com";
|
|
mountPoint = "/path/to/somewhere";
|
|
user = "root";
|
|
};
|
|
};
|
|
};
|
|
|
|
test.asserts.assertions.expected = [''
|
|
sftpman mounts using authentication type "publickey" but missing 'sshKey': mount1
|
|
''];
|
|
}
|