mirror of
https://github.com/nix-community/home-manager
synced 2025-02-17 05:35:06 +01:00
Instead of having to manually stub packages that should not be downloaded we instead automatically stub all packages (except a small list of whitelisted ones). Tests can re-introduce the real package by using the `realPkgs` module argument.
14 lines
323 B
Nix
14 lines
323 B
Nix
{
|
|
programs.ncmpcpp.enable = true;
|
|
|
|
services.mpd.enable = true;
|
|
services.mpd.musicDirectory = "/home/user/music";
|
|
|
|
nmt.script = ''
|
|
assertFileContent \
|
|
home-files/.config/ncmpcpp/config \
|
|
${./ncmpcpp-use-mpd-config-expected-config}
|
|
|
|
assertPathNotExists home-files/.config/ncmpcpp/bindings
|
|
'';
|
|
}
|