1
0
Fork 0
mirror of https://github.com/nix-community/home-manager synced 2025-02-17 05:35:06 +01:00
home-manager/tests/modules/programs/kodi/example-addon-settings.nix
Robert Helgesson 7a3f0b3b8d
tests: rework derivation stubbing
Instead of having to manually stub packages that should not be
downloaded we instead automatically stub all packages (except a small
list of whitelisted ones). Tests can re-introduce the real package by
using the `realPkgs` module argument.
2025-02-04 23:58:20 +01:00

20 lines
425 B
Nix

{ config, ... }:
{
imports = [ ./kodi-stubs.nix ];
programs.kodi = {
enable = true;
package = config.lib.test.mkStubPackage { };
addonSettings = {
"service.xbmc.versioncheck".versioncheck_enable = "false";
};
};
nmt.script = ''
assertFileContent \
home-files/.kodi/userdata/addon_data/service.xbmc.versioncheck/settings.xml \
${./example-addon-settings-expected.xml}
'';
}