mirror of
https://github.com/nix-community/home-manager
synced 2025-02-17 05:35:06 +01:00
Instead of having to manually stub packages that should not be downloaded we instead automatically stub all packages (except a small list of whitelisted ones). Tests can re-introduce the real package by using the `realPkgs` module argument.
23 lines
411 B
Nix
23 lines
411 B
Nix
{
|
|
programs.alacritty = {
|
|
enable = true;
|
|
settings = {
|
|
window.dimensions = {
|
|
lines = 3;
|
|
columns = 200;
|
|
};
|
|
|
|
keyboard.bindings = [{
|
|
key = "K";
|
|
mods = "Control";
|
|
chars = "\\u000c";
|
|
}];
|
|
};
|
|
};
|
|
|
|
nmt.script = ''
|
|
assertFileContent \
|
|
home-files/.config/alacritty/alacritty.toml \
|
|
${./example-settings-expected.toml}
|
|
'';
|
|
}
|