mirror of
https://github.com/nix-community/home-manager
synced 2025-02-17 05:35:06 +01:00
Instead of having to manually stub packages that should not be downloaded we instead automatically stub all packages (except a small list of whitelisted ones). Tests can re-introduce the real package by using the `realPkgs` module argument.
22 lines
753 B
Nix
22 lines
753 B
Nix
{ lib, realPkgs, ... }:
|
|
|
|
{
|
|
manual = {
|
|
html.enable = true;
|
|
manpages.enable = true;
|
|
json.enable = true;
|
|
};
|
|
|
|
_module.args.pkgs = lib.mkForce realPkgs;
|
|
|
|
nmt.script = ''
|
|
assertFileExists home-path/share/doc/home-manager/index.xhtml
|
|
assertFileExists home-path/share/doc/home-manager/options.json
|
|
assertFileExists home-path/share/doc/home-manager/options.xhtml
|
|
assertFileExists home-path/share/doc/home-manager/nixos-options.xhtml
|
|
assertFileExists home-path/share/doc/home-manager/nix-darwin-options.xhtml
|
|
assertFileExists home-path/share/doc/home-manager/release-notes.xhtml
|
|
assertFileExists home-path/share/man/man1/home-manager.1
|
|
assertFileExists home-path/share/man/man5/home-configuration.nix.5
|
|
'';
|
|
}
|