1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 21:13:33 +02:00
home-manager/modules/services/pulseeffects.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

71 lines
2.0 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.services.pulseeffects;
presetOpts = optionalString (cfg.preset != "") "--load-preset ${cfg.preset}";
in {
meta.maintainers = [ maintainers.jonringer ];
options.services.pulseeffects = {
enable = mkEnableOption ''
Pulseeffects daemon
Note, it is necessary to add
```nix
programs.dconf.enable = true;
```
to your system configuration for the daemon to work correctly'';
package = mkOption {
type = types.package;
default = pkgs.pulseeffects-legacy;
defaultText = literalExpression "pkgs.pulseeffects-legacy";
description = "Pulseeffects package to use.";
};
preset = mkOption {
type = types.str;
default = "";
description = ''
Which preset to use when starting pulseeffects.
Will likely need to launch pulseeffects to initially create preset.
'';
};
};
config = mkIf cfg.enable {
assertions = [
(lib.hm.assertions.assertPlatform "services.pulseeffects" pkgs
lib.platforms.linux)
];
# running pulseeffects will just attach itself to gapplication service
# at-spi2-core is to minimize journalctl noise of:
# "AT-SPI: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files"
home.packages = [ cfg.package pkgs.at-spi2-core ];
systemd.user.services.pulseeffects = {
Unit = {
Description = "Pulseeffects daemon";
Requires = [ "dbus.service" ];
After = [ "graphical-session-pre.target" ];
PartOf = [ "graphical-session.target" "pulseaudio.service" ];
};
Install = { WantedBy = [ "graphical-session.target" ]; };
Service = {
ExecStart =
"${cfg.package}/bin/pulseeffects --gapplication-service ${presetOpts}";
ExecStop = "${cfg.package}/bin/pulseeffects --quit";
Restart = "on-failure";
RestartSec = 5;
};
};
};
}