1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 21:13:33 +02:00
home-manager/modules/services/pueue.nix
Robert Helgesson 950673cec7
pueue: always write configuration file
Pueue requires the configuration file to contain a `shared` entry. We
therefore unconditionally add it as `shared: {}`.

Fixes #4295
2024-03-06 12:58:02 +01:00

61 lines
1.3 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.services.pueue;
yamlFormat = pkgs.formats.yaml { };
configFile =
yamlFormat.generate "pueue.yaml" ({ shared = { }; } // cfg.settings);
in {
meta.maintainers = [ maintainers.AndersonTorres ];
options.services.pueue = {
enable = mkEnableOption "Pueue, CLI process scheduler and manager";
package = mkPackageOption pkgs "pueue" { };
settings = mkOption {
type = yamlFormat.type;
default = { };
example = literalExpression ''
{
daemon = {
default_parallel_tasks = 2;
};
}
'';
description = ''
Configuration written to
{file}`$XDG_CONFIG_HOME/pueue/pueue.yml`.
'';
};
};
config = mkIf cfg.enable {
assertions =
[ (hm.assertions.assertPlatform "services.pueue" pkgs platforms.linux) ];
home.packages = [ cfg.package ];
xdg.configFile."pueue/pueue.yml".source = configFile;
systemd.user = {
services.pueued = {
Unit = {
Description = "Pueue Daemon - CLI process scheduler and manager";
};
Service = {
Restart = "on-failure";
ExecStart = "${cfg.package}/bin/pueued -v -c ${configFile}";
};
Install.WantedBy = [ "default.target" ];
};
};
};
}