mirror of
https://github.com/nix-community/home-manager
synced 2024-11-23 03:29:45 +01:00
1743615b61
Adds a new Podman module for creating user containers and networks as systemd services. These are installed to the user's `$XDG_CONFIG/systemd/user` directory.
17 lines
455 B
Nix
17 lines
455 B
Nix
{ config, pkgs, lib, ... }:
|
|
|
|
{
|
|
meta.maintainers = with lib.hm.maintainers; [ bamhm182 n-hass ];
|
|
|
|
imports =
|
|
[ ./containers.nix ./install-quadlet.nix ./networks.nix ./services.nix ];
|
|
|
|
options.services.podman = {
|
|
enable = lib.mkEnableOption "Podman, a daemonless container engine";
|
|
};
|
|
|
|
config = lib.mkIf config.services.podman.enable {
|
|
assertions =
|
|
[ (lib.hm.assertions.assertPlatform "podman" pkgs lib.platforms.linux) ];
|
|
};
|
|
}
|