1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 21:13:33 +02:00
home-manager/modules/services/mbsync.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

107 lines
2.7 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.services.mbsync;
mbsyncOptions = [ "--all" ] ++ optional (cfg.verbose) "--verbose"
++ optional (cfg.configFile != null) "--config ${cfg.configFile}";
in {
meta.maintainers = [ maintainers.pjones ];
options.services.mbsync = {
enable = mkEnableOption "mbsync";
package = mkOption {
type = types.package;
default = pkgs.isync;
defaultText = literalExpression "pkgs.isync";
example = literalExpression "pkgs.isync";
description = "The package to use for the mbsync binary.";
};
frequency = mkOption {
type = types.str;
default = "*:0/5";
description = ''
How often to run mbsync. This value is passed to the systemd
timer configuration as the onCalendar option. See
{manpage}`systemd.time(7)`
for more information about the format.
'';
};
verbose = mkOption {
type = types.bool;
default = true;
description = ''
Whether mbsync should produce verbose output.
'';
};
configFile = mkOption {
type = types.nullOr types.path;
default = null;
description = ''
Optional configuration file to link to use instead of
the default file ({file}`~/.mbsyncrc`).
'';
};
preExec = mkOption {
type = types.nullOr types.str;
default = null;
example = "mkdir -p %h/mail";
description = ''
An optional command to run before mbsync executes. This is
useful for creating the directories mbsync is going to use.
'';
};
postExec = mkOption {
type = types.nullOr types.str;
default = null;
example = "\${pkgs.mu}/bin/mu index";
description = ''
An optional command to run after mbsync executes successfully.
This is useful for running mailbox indexing tools.
'';
};
};
config = mkIf cfg.enable {
assertions = [
(lib.hm.assertions.assertPlatform "services.mbsync" pkgs
lib.platforms.linux)
];
systemd.user.services.mbsync = {
Unit = { Description = "mbsync mailbox synchronization"; };
Service = {
Type = "oneshot";
ExecStart =
"${cfg.package}/bin/mbsync ${concatStringsSep " " mbsyncOptions}";
} // (optionalAttrs (cfg.postExec != null) {
ExecStartPost = cfg.postExec;
}) // (optionalAttrs (cfg.preExec != null) {
ExecStartPre = cfg.preExec;
});
};
systemd.user.timers.mbsync = {
Unit = { Description = "mbsync mailbox synchronization"; };
Timer = {
OnCalendar = cfg.frequency;
Unit = "mbsync.service";
};
Install = { WantedBy = [ "timers.target" ]; };
};
};
}