1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 21:13:33 +02:00
home-manager/modules/services/kbfs.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

65 lines
1.5 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.services.kbfs;
in {
options = {
services.kbfs = {
enable = mkEnableOption "Keybase File System";
mountPoint = mkOption {
type = types.str;
default = "keybase";
description = ''
Mount point for the Keybase filesystem, relative to
{env}`HOME`.
'';
};
extraFlags = mkOption {
type = types.listOf types.str;
default = [ ];
example = [ "-label kbfs" "-mount-type normal" ];
description = ''
Additional flags to pass to the Keybase filesystem on launch.
'';
};
};
};
config = mkIf cfg.enable {
assertions = [
(lib.hm.assertions.assertPlatform "services.kbfs" pkgs
lib.platforms.linux)
];
systemd.user.services.kbfs = {
Unit = {
Description = "Keybase File System";
Requires = [ "keybase.service" ];
After = [ "keybase.service" ];
};
Service = let mountPoint = ''"%h/${cfg.mountPoint}"'';
in {
Environment = "PATH=/run/wrappers/bin KEYBASE_SYSTEMD=1";
ExecStartPre = "${pkgs.coreutils}/bin/mkdir -p ${mountPoint}";
ExecStart =
"${pkgs.kbfs}/bin/kbfsfuse ${toString cfg.extraFlags} ${mountPoint}";
ExecStopPost = "/run/wrappers/bin/fusermount -u ${mountPoint}";
Restart = "on-failure";
PrivateTmp = true;
};
Install.WantedBy = [ "default.target" ];
};
home.packages = [ pkgs.kbfs ];
services.keybase.enable = true;
};
}