1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 21:13:33 +02:00
home-manager/modules/services/fluidsynth.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

69 lines
1.7 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.services.fluidsynth;
in {
meta.maintainers = [ maintainers.valodim ];
options = {
services.fluidsynth = {
enable = mkEnableOption "fluidsynth midi synthesizer";
soundFont = mkOption {
type = types.path;
default = "${pkgs.soundfont-fluid}/share/soundfonts/FluidR3_GM2-2.sf2";
description = ''
The soundfont file to use, in SoundFont 2 format.
'';
};
soundService = mkOption {
type = types.enum [ "jack" "pipewire-pulse" "pulseaudio" ];
default = "pulseaudio";
example = "pipewire-pulse";
description = ''
The systemd sound service to depend on.
'';
};
extraOptions = mkOption {
type = types.listOf types.str;
default = [ ];
example = [ "--sample-rate 96000" ];
description = ''
Extra arguments, added verbatim to the fluidsynth command. See
{manpage}`fluidsynth.conf(1)`.
'';
};
};
};
config = mkIf cfg.enable {
assertions = [
(lib.hm.assertions.assertPlatform "services.fluidsynth" pkgs
lib.platforms.linux)
];
systemd.user.services.fluidsynth = {
Unit = {
Description = "FluidSynth Daemon";
Documentation = "man:fluidsynth(1)";
BindsTo = [ (cfg.soundService + ".service") ];
After = [ (cfg.soundService + ".service") ];
};
Install = { WantedBy = [ "default.target" ]; };
Service = {
ExecStart = "${pkgs.fluidsynth}/bin/fluidsynth -a pulseaudio -si ${
lib.concatStringsSep " " cfg.extraOptions
} ${cfg.soundFont}";
};
};
};
}