1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 21:13:33 +02:00
home-manager/modules/services/caffeine.nix
Richard Davis 093777ee4a
caffeine: remove ProtectHome service option
This option causes caffeine to be unable to start via the systemd
service.
2023-12-10 08:37:02 +01:00

38 lines
769 B
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.services.caffeine;
in {
meta.maintainers = [ maintainers.uvnikita ];
options = {
services.caffeine = { enable = mkEnableOption "Caffeine service"; };
};
config = mkIf cfg.enable {
assertions = [
(lib.hm.assertions.assertPlatform "services.caffeine" pkgs
lib.platforms.linux)
];
systemd.user.services.caffeine = {
Unit = { Description = "caffeine"; };
Install = { WantedBy = [ "graphical-session.target" ]; };
Service = {
Restart = "on-failure";
PrivateTmp = true;
ProtectSystem = "full";
Type = "exec";
Slice = "session.slice";
ExecStart = "${pkgs.caffeine-ng}/bin/caffeine";
};
};
};
}