1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 13:03:33 +02:00
home-manager/modules/programs/zplug.nix
Sinkerine 27d89b49e3
zplug: Update the path of init.zsh (#3922)
The current zplug nixpkgs puts everything under `$out/`. It pollutes the nix
profile dir.

This is a breaking change. It depends on an change of the output path in the
nixpkgs zplug package.
2023-04-29 11:08:16 +02:00

71 lines
1.4 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.programs.zsh.zplug;
pluginModule = types.submodule ({ config, ... }: {
options = {
name = mkOption {
type = types.str;
description = "The name of the plugin.";
};
tags = mkOption {
type = types.listOf types.str;
default = [ ];
description = "The plugin tags.";
};
};
});
in {
options.programs.zsh.zplug = {
enable = mkEnableOption "zplug - a zsh plugin manager";
plugins = mkOption {
default = [ ];
type = types.listOf pluginModule;
description = "List of zplug plugins.";
};
zplugHome = mkOption {
type = types.path;
default = "${config.home.homeDirectory}/.zplug";
defaultText = "~/.zplug";
apply = toString;
description = "Path to zplug home directory.";
};
};
config = mkIf cfg.enable {
home.packages = [ pkgs.zplug ];
programs.zsh.initExtraBeforeCompInit = ''
export ZPLUG_HOME=${cfg.zplugHome}
source ${pkgs.zplug}/share/zplug/init.zsh
${optionalString (cfg.plugins != [ ]) ''
${concatStrings (map (plugin: ''
zplug "${plugin.name}"${
optionalString (plugin.tags != [ ]) ''
${concatStrings (map (tag: ", ${tag}") plugin.tags)}
''
}
'') cfg.plugins)}
''}
if ! zplug check; then
zplug install
fi
zplug load
'';
};
}