1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 13:03:33 +02:00
home-manager/modules/programs/sagemath.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

64 lines
1.7 KiB
Nix

{ config, lib, pkgs, ... }:
let
cfg = config.programs.sagemath;
inherit (lib) literalExpression mkEnableOption mkOption types;
in {
meta.maintainers = [ lib.maintainers.kirelagin ];
options.programs.sagemath = {
enable = mkEnableOption "SageMath, a mathematics software system";
package = mkOption {
type = types.package;
default = pkgs.sage;
defaultText = literalExpression "pkgs.sage";
description = "The SageMath package to use.";
};
configDir = mkOption {
type = types.str;
default = "${config.xdg.configHome}/sage";
defaultText = literalExpression "\${config.xdg.configHome}/sage";
description = ''
Directory where the {file}`sage.init` file will be stored.
Note that the upstream default is {file}`~/.sage`,
but our default is to follow XDG.
'';
};
dataDir = mkOption {
type = types.str;
default = "${config.xdg.dataHome}/sage";
defaultText = literalExpression "\${config.xdg.dataHome}/sage";
description = ''
Location for {env}`DOT_SAGE`.
Note that the upstream default is {file}`~/.sage`,
but our default is to follow XDG.
'';
};
initScript = mkOption {
type = types.lines;
default = "";
example = "%colors linux";
description = ''
Contents of the {file}`init.sage` file that is loaded on startup.
'';
};
};
config = lib.mkIf cfg.enable {
home.packages = [ cfg.package ];
home.file."${cfg.configDir}/init.sage".text = cfg.initScript;
home.sessionVariables = {
DOT_SAGE = cfg.dataDir;
SAGE_STARTUP_FILE = "${cfg.configDir}/init.sage";
};
};
}