1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 13:03:33 +02:00
home-manager/modules/programs/pet.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

108 lines
2.4 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.programs.pet;
format = pkgs.formats.toml { };
snippetType = types.submodule {
options = {
description = mkOption {
type = types.str;
default = "";
example = "Count the number of commits in the current branch";
description = ''
Description of the snippet.
'';
};
command = mkOption {
type = types.str;
default = "";
example = "git rev-list --count HEAD";
description = ''
The command.
'';
};
output = mkOption {
type = types.str;
default = "";
example = "473";
description = ''
Example output of the command.
'';
};
tag = mkOption {
type = types.listOf types.str;
default = [ ];
example = literalExpression ''["git" "nixpkgs"]'';
description = ''
List of tags attached to the command.
'';
};
};
};
in {
options.programs.pet = {
enable = mkEnableOption "pet";
settings = mkOption {
type = format.type;
default = { };
description = ''
Settings written to {file}`config.toml`. See the pet
documentation for details.
'';
};
selectcmdPackage = mkOption {
type = types.package;
default = pkgs.fzf;
defaultText = literalExpression "pkgs.fzf";
description = ''
The package needed for the {var}`settings.selectcmd`.
'';
};
snippets = mkOption {
type = types.listOf snippetType;
default = [ ];
description = ''
The snippets.
'';
};
};
config = mkIf cfg.enable {
programs.pet.settings = let
defaultGeneral = {
selectcmd = mkDefault "fzf";
snippetfile = config.xdg.configHome + "/pet/snippet.toml";
};
in if versionAtLeast config.home.stateVersion "21.11" then {
General = defaultGeneral;
} else
defaultGeneral;
home.packages = [ pkgs.pet cfg.selectcmdPackage ];
xdg.configFile = {
"pet/config.toml".source = format.generate "config.toml"
(if versionAtLeast config.home.stateVersion "21.11" then
cfg.settings
else {
General = cfg.settings;
});
"pet/snippet.toml" = mkIf (cfg.snippets != [ ]) {
source = format.generate "snippet.toml" { snippets = cfg.snippets; };
};
};
};
}