1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 13:03:33 +02:00
home-manager/modules/programs/notmuch-virtual-mailbox.nix
Ryan Lahfa 0263da497e
notmuch & neomutt: Control virtualboxes being set in NeoMutt for Notmuch integration (#3143)
Virtual mailboxes (described by Notmuch queries) can now configured for each account in NeoMutt.
Plus, it is possible to disable Notmuch section for a specific account.
2023-04-24 16:41:29 +02:00

34 lines
805 B
Nix

{ config, lib, ... }:
with lib; {
options = {
name = mkOption {
type = types.str;
example = "My INBOX";
default = "My INBOX";
description = "Name to display";
};
query = mkOption {
type = types.str;
example = "tag:inbox";
default = "tag:inbox";
description = "Notmuch query";
};
limit = mkOption {
type = types.nullOr types.int;
example = 10;
default = null;
description = "Restricts number of messages/threads in the result.";
};
type = mkOption {
type = types.nullOr (types.enum ([ "threads" "messages" ]));
example = "threads";
default = null;
description =
"Reads all matching messages or whole-threads. The default is 'messages' or nm_query_type.";
};
};
}