1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 13:03:33 +02:00
home-manager/modules/programs/ne.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

96 lines
2.1 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.programs.ne;
autoPrefFiles = let
autoprefs = cfg.automaticPreferences
// optionalAttrs (cfg.defaultPreferences != "") {
".default" = cfg.defaultPreferences;
};
gen = fileExtension: configText:
nameValuePair ".ne/${fileExtension}#ap" {
text = configText;
}; # Generates [path].text format expected by home.file.
in mapAttrs' gen autoprefs;
in {
meta.maintainers = [ hm.maintainers.cwyc ];
options.programs.ne = {
enable = mkEnableOption "ne";
keybindings = mkOption {
type = types.lines;
default = "";
example = ''
KEY 7f BS
SEQ "\x1b[1;5D" 7f
'';
description = ''
Keybinding file for ne.
'';
};
defaultPreferences = mkOption {
type = types.lines;
default = "";
description = ''
Default preferences for ne.
Equivalent to `programs.ne.automaticPreferences.".default"`.
'';
};
automaticPreferences = mkOption {
type = types.attrsOf types.lines;
default = { };
example = literalExpression ''
{
nix = '''
TAB 0
TS 2
''';
js = '''
TS 4
''';
}
'';
description = ''
Automatic preferences files for ne.
'';
};
menus = mkOption {
type = types.lines;
default = "";
description = "Menu configuration file for ne.";
};
virtualExtensions = mkOption {
type = types.lines;
default = "";
example = ''
sh 1 ^#!\s*/.*\b(bash|sh|ksh|zsh)\s*
csh 1 ^#!\s*/.*\b(csh|tcsh)\s*
'';
description = "Virtual extensions configuration file for ne.";
};
};
config = mkIf cfg.enable {
home.packages = [ pkgs.ne ];
home.file = {
".ne/.keys" = mkIf (cfg.keybindings != "") { text = cfg.keybindings; };
".ne/.extensions" =
mkIf (cfg.virtualExtensions != "") { text = cfg.virtualExtensions; };
".ne/.menus" = mkIf (cfg.menus != "") { text = cfg.menus; };
} // autoPrefFiles;
};
}