1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 13:03:33 +02:00
home-manager/modules/programs/khal-contact-accounts.nix
Felipe Silva d579633ff9
khal: fix contact integration (#4836)
* khal: fix contact integration

- Add tests for contact+khal
- Make options `color`/`priority` available for contact accounts

* khal: add separate calendar for each contact collection

A contact account may have multiple VCARD collections, but Khal doesn't
search recursively. Collection folder names must be hardcoded, and each
has its own calendar.

- Add khal.collections option for contact accounts
- Default to previous setup for accounts with a single collection
- Add tests

* khal: specify how priority is defined by Khal

See https://khal.readthedocs.io/en/latest/configure.html
2024-03-03 18:12:42 +01:00

16 lines
269 B
Nix

{ config, lib, ... }:
with lib;
{
options.khal = {
collections = mkOption {
type = types.nullOr (types.listOf types.str);
default = null;
description = ''
VCARD collections to be searched for contact birthdays.
'';
};
};
}