1
0
mirror of https://github.com/nix-community/home-manager synced 2024-06-02 13:03:33 +02:00
home-manager/modules/programs/havoc.nix
Emily 9f9e277b60 treewide: remove now-redundant lib.mdDoc calls
These (and the `*MD` functions apart from `literalMD`) are now no-ops
in nixpkgs and serve no purpose other than to add additional noise and
potentially mislead people into thinking unmarked DocBook documentation
will still be accepted.

Note that if backporting changes including documentation to 23.05,
the `mdDoc` calls will need to be re-added.

To reproduce this commit, run:

    $ NIX_PATH=nixpkgs=flake:nixpkgs/e7e69199f0372364a6106a1e735f68604f4c5a25 \
      nix shell nixpkgs#coreutils \
      -c find . -name '*.nix' \
      -exec nix run -- github:emilazy/nix-doc-munge/98dadf1f77351c2ba5dcb709a2a171d655f15099 \
      --strip {} +
    $ ./format
2023-07-17 18:49:09 +01:00

64 lines
1.6 KiB
Nix

{ config, lib, pkgs, ... }:
with lib;
let
cfg = config.programs.havoc;
iniFormat = pkgs.formats.ini { };
in {
meta.maintainers = with lib.maintainers; [ AndersonTorres ];
options.programs.havoc = {
enable = mkEnableOption "Havoc terminal";
package = mkPackageOption pkgs "havoc" { };
settings = mkOption {
type = iniFormat.type;
default = { };
description = ''
Configuration written to
{file}`$XDG_CONFIG_HOME/havoc.cfg`. See <https://raw.githubusercontent.com/ii8/havoc/master/havoc.cfg>
for a list of available options.
'';
example = literalExpression ''
{
child.program = "bash";
window.opacity = 240;
window.margin = no;
terminal = {
rows = 80;
columns = 24;
scrollback = 2000;
};
bind = {
"C-S-c" = "copy";
"C-S-v" = "paste";
"C-S-r" = "reset";
"C-S-Delete" = "hard reset";
"C-S-j" = "scroll down";
"C-S-k" = "scroll up";
"C-S-Page_Down" = "scroll down page";
"C-S-Page_Up" = "scroll up page";
"C-S-End" = "scroll to bottom";
"C-S-Home" = "scroll to top";
};
}
'';
};
};
config = mkIf cfg.enable {
assertions =
[ (hm.assertions.assertPlatform "programs.havoc" pkgs platforms.linux) ];
home.packages = [ cfg.package ];
xdg.configFile."havoc.cfg" = mkIf (cfg.settings != { }) {
source = iniFormat.generate "havoc.cfg" cfg.settings;
};
};
}