mirror of
https://github.com/unclechu/gRPC-haskell.git
synced 2024-11-14 23:29:42 +01:00
15 lines
531 B
Nix
15 lines
531 B
Nix
{ mkDerivation, base, bytestring, Only, optparse-applicative
|
|
, semigroups, stdenv, system-filepath, text, time, transformers
|
|
, void
|
|
}:
|
|
mkDerivation {
|
|
pname = "optparse-generic";
|
|
version = "1.3.0";
|
|
sha256 = "80929958606e4a73672b570ba1a23493fbf46268666d14ab5af53623301c398f";
|
|
libraryHaskellDepends = [
|
|
base bytestring Only optparse-applicative semigroups
|
|
system-filepath text time transformers void
|
|
];
|
|
description = "Auto-generate a command-line parser for your datatype";
|
|
license = stdenv.lib.licenses.bsd3;
|
|
}
|