gRPC-haskell/nix/proto3-wire.nix
przemyslaw wierzbicki 68ce43f183 nixpkgs upgrade
2019-05-23 21:43:05 -04:00

25 lines
875 B
Nix

{ mkDerivation, base, bytestring, cereal, containers, deepseq
, doctest, fetchgit, hashable, QuickCheck, safe, stdenv, tasty
, tasty-hunit, tasty-quickcheck, text, unordered-containers
}:
mkDerivation {
pname = "proto3-wire";
version = "1.0.0";
src = fetchgit {
url = "https://github.com/awakenetworks/proto3-wire.git";
sha256 = "0ddza0s9ms51nb5qk97h8wj2p1bqpwwrfdv9fzdc5xf48khzmxki";
rev = "43d8220dbc64ef7cc7681887741833a47b61070f";
fetchSubmodules = true;
};
libraryHaskellDepends = [
base bytestring cereal containers deepseq hashable QuickCheck safe
text unordered-containers
];
testHaskellDepends = [
base bytestring cereal doctest QuickCheck tasty tasty-hunit
tasty-quickcheck text
];
description = "A low-level implementation of the Protocol Buffers (version 3) wire format";
license = stdenv.lib.licenses.asl20;
}